极品公式集--章三丰

YONGHUA.NET 来源: 发布时间:2006-06-10 19:08:18 发布人: 浏览: 人次


三丰公式源码
三丰礼物1  MACD、RSI、KDJ、TRIX同图显示组合指标
RSI6:SMA(MAX(C-REF(C,1),0),6,1)/SMA(ABS(C-REF(C,1)),6,1)*100;
DIFF:=EMA(C,5)-EMA(C,20);DEA:=EMA(DIFF,10);
MACD:500*(DIFF-DEA)/EMA(C,30) colorred pointdot;
RSV:=(C-LLV(L,20))/(HHV(H,20)-LLV(L,20))*100;
FK:=SMA(RSV,5,1);
K20:SMA(FK,5,1) pointdot COLORyellow;
D20:SMA(K20,5,1) pointdot COLORff9999;
TR:=EMA(EMA(EMA(C,5),5),5);
TRIX:(TR-REF(TR,1))/REF(TR,1)*1000 pointdot colormagenta;
TRMA:EMA(TRIX,30) pointdot colorff8888;
STICKLINE(K20>=D20,D20,K20,10,0) COLORyellow;
STICKLINE(K20<=D20,D20,K20,10,0) COLORff9999;
STICKLINE(MACD>=0,0,MACD,10,0) COLORred;
STICKLINE(MACD<=0,0,MACD,10,0) COLORgreen;
STICKLINE(TRIX>=TRMA,TRIX+60,TRMA+60,10,0) COLORmagenta;
STICKLINE(TRIX<=TRMA,TRIX+60,TRMA+60,10,0) COLORff9999;
三丰礼物2   MACD、RSI、日周KDJ同图显示组合指标
Rsi6:SMA(MAX(C-REF(C,1),0),6,1)/SMA(ABS(C-REF(C,1)),6,1)*100;
MACD:300*"MACD.MACD#DAY"(20,5,10)/EMA(C,30) colorred pointdot;
日K:"SLOWKD.K#DAY"(20,5,5,5) pointdot COLORyellow;
日D:"SLOWKD.D#DAY"(20,5,5,5) pointdot COLORff9999;
周K:"SLOWKD.K#WEEK"(5,3,3,3) pointdot COLORmagenta;
周D:"SLOWKD.D#WEEK"(5,3,3,3) pointdot COLORff9999;
STICKLINE(日K>=日D,日D,日K,10,0) COLORyellow;
STICKLINE(日K<日D,日D,日K,10,0) COLORff9999;
STICKLINE(周K>=周D,周D,周K,10,0) COLORmagenta;
STICKLINE(周K<周D,周K,周D,10,0) COLORff9999;
STICKLINE(MACD>=0,0,MACD,10,0) COLORred;
STICKLINE(MACD<=0,0,MACD,10,0) COLORgreen;

三丰礼物3  MACD、日周KDJ同图显示组合主图指标
MA10:MA(C,10);
MA30:MA(C,30);
MA60:MA(C,60);
MA90:MA(C,90);
MA120:MA(C,120) colorgreen;
MACD:="MACD.MACD"(20,5,10);
K20:="SLOWKD.K"(20,5,5,5);
D20:="SLOWKD.D"(20,5,5,5);
周K:="SLOWKD.K#WEEK"(5,3,3,3);
周D:="SLOWKD.D#WEEK"(5,3,3,3);
L000:=(K20>=D20 AND MACD>=0) OR (周K>=周D
AND MACD>=0) OR (周K>=周D AND K20>=D20);
L001:=K20>=D20 AND 周K>=周D AND MACD>=0;
STICKLINE(L001=0,C,O,6,0) COLORff8888;
STICKLINE(L001=0,H,L,0,0) COLORff8888;
STICKLINE(L000>0,C,O,6,0) COLORyellow;
STICKLINE(L000>0,H,L,0,0) COLORyellow;
STICKLINE(L001>0,C,O,6,0) COLORred;
STICKLINE(L001>0,H,L,0,0) COLORred;
STICKLINE(C<=REF(C,1) AND L001>0,C,O,6,0) COLORgreen;
STICKLINE(C<=REF(C,1) AND L001>0,H,L,0,0) COLORgreen;

SF庄见愁
  庄家筹码估算值:EMA(WINNER(C)*70,3) colormagenta linethick2;
  散户筹码估算值:EMA((WINNER(C*1.1)-WINNER(C*0.9))*70,3) colorgreen linethick2;

SF庄见愁Z
获利线:EMA(WINNER(C)*100,3) colorwhite;
庄筹线:EMA(WINNER(C)*70,5) colorred linethick2;
散筹线:EMA((WINNER(C*1.1)-WINNER(C*0.9))*70,5)colorgreen linethick2;
收:=winner(C)*100;开:=winner(O)*100;
博弈K线长:MAX(ABS(收-开),ABS(收-REF(收,1)))pointdot colormagenta;
STICKLINE(庄筹线>散筹线,庄筹线,散筹线,0,0),COLORred;
stickline(收>REF(收,1),0,博弈K线长,6,0),colormagenta;
stickline(收<REF(收,1),0,博弈K线长,0,0),color999999;

SF太极拳
  KS13:=(CLOSE-MA(CLOSE,13))/MA(CLOSE,13)*(-100);
  REF(KS13,1)>=16 AND REF(KS13,1)/KS13>=1.23;

大道至简,三丰KDJ指标
三丰KDJ指标的原码:
CC:=WINNER(CLOSE)*100;
CO:=WINNER(OPEN)*100;
CH:=WINNER(HIGH)*100;
CL:=WINNER(LOW)*100;
RSV:=(CC-LLV(CL,20))/(HHV(CH,20)-LLV(CL,20))*100;
FK:=SMA(RSV,5,1); K:SMA(FK,5,1);
D:SMA(K,5,1); J: K*3-D*2;
见底买入:IF(REF(K,1)<20 AND CROSS(K,D),30,00)linethick2,colorred;
见顶卖出:IF(REF(K,1)>80 AND CROSS(D,K),60,90)linethick2 colorgreen;

大道至简,三丰MACD指标
三丰MACD指标的原码:
CC:=WINNER(CLOSE)*100;
DIFF:EMA(CC,5)-EMA(CC,20);
DEA:EMA(DIFF,10);
MACD:(DIFF-DEA),COLORSTICK LINETHICK3;

大道至简,三丰TRIX指标
三丰TRIX指标的原码:
CC:=WINNER(CLOSE)*100;
TR:=EMA(EMA(EMA(CC,10),10),10);
TRIX:(TR-REF(TR,1))/REF(TR,1)*100;
TRMA:EMA(TRIX,20);

大道至简,三丰RSI指标
三丰RSI指标的原码:
CC:=WINNER(C);CO:=WINNER(O);CH:=WINNER(H);CL:=WINNER(L);LC:=REF(CC,1);
RSI1:SMA(SMA(MAX(CC-LC,0),6,1)/SMA(ABS(CC-LC),6,1)*100,5,1);
RSI2:SMA(SMA(MAX(CC-LC,0),12,1)/SMA(ABS(CC-LC),12,1)*100,5,1);
RSI3:SMA(SMA(MAX(CC-LC,0),24,1)/SMA(ABS(CC-LC),24,1)*100,5,1);

大道至简,三丰MA指标
三丰MA指标的原码:
CC:=WINNER(C)*100;
MA10:MA(CC,10);
MA30:MA(CC,30);
MA90:MA(CC,90);
MA120:MA(CC,120);
MA250:MA(CC,250);

大道至简,三丰波段指标
首先,声明一点:本指标非我所创,是优化别人的东西而成。
三丰“波段神偷”指标的原码:
Var1:=3*SMA((C-LLV(L,55))/(HHV(H,55)-LLV(L,55))*100,5,1)
-2*SMA(SMA((C-LLV(L,55))/(HHV(H,55)-LLV(L,55))*100,5,1),3,1);
三丰线:EMA(Var1,5) linethick2;
Var2:=(三丰线-REF(三丰线,1))/REF(三丰线,1)*100;
准备资金:STICKLINE(三丰线<13,0,20,5,0)COLORyellow;
买入股票:STICKLINE(REF(三丰线,1)<13 AND Var2>13,0,50,5,0)COLORred;
见顶清仓:STICKLINE(REF(三丰线,1)>90 AND Var2<0,100,80,5,0)COLORgreen;
0 linethick2 color999999;100 linethick2 color999999;

1板桥宝剑
A:=MA(MA(C,23),13);
满仓:MA(A*0.65,5);
低吸:MA(A*0.8,5);
STICKLINE(C>=O,H,L,0,0) COLORred;
STICKLINE(C>=O,C,O,6,0) COLORred;
STICKLINE(C<=O,H,L,0,0) COLORgreen;
STICKLINE(C<=O,C,O,6,0) COLORgreen;

2命运之神
Var1:=(C-LLV(L,100))/(HHV(H,100)-LLV(L,100))*100;
Var2:=SMA(Var1,3,1);Var3:=SMA(Var2,3,1);Var4:=3*Var2-2*Var3;
Var7:=EMA((C-LLV(L,5))/(HHV(H,5)-HHV(H,5))*100,4);
Var8:=EMA(0.667*REF(Var7,1)+0.333*Var7,2);Var9:=3*Var7-2*Var8;
Var11:=(H+L+C*2)/4;Var14:=(Var11-EMA(Var11,13))/STD(Var11,13)*100;
Var17:=EMA(EMA(Var14,5),13)+50;Var18:=EMA(Var17,10);Var19:=3*Var17-2*Var18;
Var1A:=Var2+Var7+Var17;Var1B:=Var3+Var8 +Var18;Var1C:=Var4+Var9+Var19;
Var1D:=(H+L+C)/3;Var20:=(Var1D-MA(Var1D,34))/(0.015*AVEDEV(Var1D,34));
Var2A:=Var20/4+50;Var21:=DMA(AMOUNT/V/100,V/CAPITAL);
Var2B:=EMA(EMA(EMA(Var2A,5),5),5)*2-50+Var21;Var2C:=(Var1A+Var1B+Var1C)/3;
Var2D:=EMA(Var2C,13);Var2E:=(Var2A+Var2C)/2;
短线:Var2E;
中线:(Var2B+Var2D)/2;


3金山
varc:=sma(abs(l-ref(l,1)),3,1)/sma(max(l-ref(l,1),0),3,1);
金山:ema(if(l<= llv(l,30),varc,0),3);

4闪电之王
VarF:=TROUGHBARS(3,15,1)<4;
升跌:EMA((C/MA((2*C+H+L)/4,30)-1)*100,3)colorstick;
PARTLINE(C,升跌)colorgreen;
PARTLINE(C,0)colorred,linethick2;
STICKLINE(FILTER(VarF=1,5),50,0,10,0)colorblue;
DRAWICON(FILTER(VarF=1,5),50,1);
DRAWTEXT(FILTER(VarF=1,5),25,'闪电出击')coloryellow;

5反转点
反转点1:llv(l,3)=llv(l,120) and c/ref(c,1)>=1.06,colorred,linethick2;
drawicon(反转点1,1,1);
var4:=(c-ma(c,24))/ma(c,24)*100;
反转点2:cross(var4,-20)+1,linethick2;
drawicon(cross(var4,-20),2,1)coloryellow;

6无名氏
COUNT(C/MA(C,48)<0.67,3) AND H>L*1.06 AND C/COST(8)<0.8;

7筹码均线
ww:=WINNER((h+l+o+c)/4)*100;
MA5:ma(ww,5);MA13:ma(ww,13);MA30:ma(ww,30);

8屠龙宝刀
虎线:EMA((WINNER(C)*"LFS@LFS")*("CYC@CYC13"/MA(C,13)),5),COLORYELLOW;
基准:EMA((WINNER(C)*"LFS@LFS")*("CYC@CYC13"/MA(C,13)),13),COLORRED;
龙线:EMA(("CYC@CYC13"/MA(C,13))*WINNER(C)*(100-"LFS@LFS"),5),COLORMAGENTA;
stickline(龙线>ref(龙线,1),龙线,基准,0,0),colorred;
stickline(龙线< ref(龙线,1),龙线,基准,0,0),colorgreen;
stickline(虎线>基准,虎线,基准,0,0),colorred;
stickline(虎线< 基准,虎线,基准,0,0),colorgreen;

9万元指标
售价万元:0,POINTDOT;
Var6:=(MA(C,5)+MA(C,10)+MA(C,20)+MA(C,30))/4;
Var7:=(Var6-REF(Var6,15))/REF(Var6,15)*100;
Var8:=(Var6-REF(Var6,15))/REF(Var6,15)*100;
Var9:=EMA(Var7,8);
反转:STICKLINE(Var9>REF(Var9,1),Var7,0,5,0)COLOREE00EE;
持股:STICKLINE(Var7>REF(Var7,1),Var7,Var9,5,0)COLORRED;
持币:STICKLINE(Var7< REF(Var7,1),Var7,Var9,5,1)COLORGREEN;
洗盘:STICKLINE(Var7< REF(Var7,1)
AND Var9>REF(Var9,1),Var7,Var9,10,0)COLOR00EEFF;
Var10:=(C-MA(C,58))/MA(C,58)*100;
Var11:=(Var10>1*REF(Var10,1) AND Var10<-26)*1.5;
Var12:=V/CAPITAL*100;Var13:=LLVBARS(L,50);
Var14:=SUM(V,Var13);Var15:=HHVBARS(H,50);Var16:=SUM(V,Var15);
Var17:=(C-REF(O,Var15))/REF(O,Var15)*100;
Var18:=Var16/CAPITAL*100;
Var19:=(C-REF(O,Var13))/REF(O,Var13)*100;
Var20:=Var14/CAPITAL*100;
Var21:=MA(C,3);Var22:=REF(C,2)*0.865;
Var23:=REF(C,13)*0.772;
Var24:=MIN(Var22,Var23);
Var25:=MA(C,13);
抄底王:IF((C-Var24)/C< 0.030 AND Var17<-35 AND
SUM(Var12,5)/5< 1.8,1,0)*10,COLORWHITE;
DRAWTEXT(抄底王,抄底王,'成功率90.22%'),COLORFFAA00;
Var26:=(C-REF(C,1))/REF(C,1)*100;
Var27:=(EMA(C,12)-EMA(C,26))*100;
Var28:=EMA(Var27,9);
Var29:=2*(Var27-Var28);
DRAWTEXT(Var27<-50 AND Var26>7 AND Var27DRAWTEXT(Var27<-50 AND Var26>7 AND Var27>=Var28,5,'追')COLORWHITE;
STICKLINE(Var27<-50 AND Var26>7,0,-10,5,0),COLORFFFF66;

A抄底之尊
BIAS1:=(C/MA(C,6)-1)*100;
BIAS2:=(C/MA(C,12)-1)*100;
BIAS3:=(C/MA(C,24)-1)*100;
AA1:=((MA(AMOUNT,5)/MA(V,5)-MA(AMOUNT,110)/MA(V,110))
/(MA(AMOUNT,5)/MA(V,5)))< -0.273;
AA1 and BIAS1<=-7 AND BIAS2<=-11 AND BIAS3<=-14;

B庄见愁
庄筹估算:EMA(WINNER(C)*70,5) colormagenta linethick2;
散筹估算:EMA((WINNER(C*1.1)-WINNER(C*0.9))*80,5) colorgreen linethick2;

C底部动量
VAR4:=SMA(ABS(L-REF(L,1)),13,1)/SMA(MAX(L-REF(l,1),0),13,1);
底部动量:EMA(IF(L<=LLV(l,30),VAR4,0),3)*10,COLORA0A0FF;

D火焰山
varc:=sma(abs(l-ref(l,1)),3,1)/sma(max(l-ref(l,1),0),3,1);
vard:=ema(if(c< ema(c,250),varc*1000,varc*10),3);
火焰山:ema(if(l<=llv(l,30),vard/2+hhv(vard,30),0),3)/618;
stickline(火焰山>100,0,火焰山*1.2,8,0);
stickline(火焰山>100,0,火焰山,4,1);

E牛气冲天(主图指标)
箱顶:hhv(ma(c,5),58);
箱底:llv(ma(c,6),58);
MA3:MA(C,3);
MA34:MA(C,34);

F子午线
X:=(C-LLV(L,24))/(HHV(H,24)-LLV(L,24))*100;
子:SMA(X,5,1) COLORYELLOW;
午:100-子 COLORFF00FF;

G光棍翻脸
VarC:=EMA(((2*C+H+L)/4-LLV(L,34))/(HHV(H,34)-LLV(L,34))*100,8);
VarD:=EMA(VarC,5);
STICKLINE(VarC-VarD>=0,79,80,6,0),colorgreen;
STICKLINE(VarC-VarD< 0,79,80,6,1),colorred;
STICKLINE(VarC-VarD>=0,19,20,6,0),colorgreen;
STICKLINE(VarC-VarD>=0,49,50,6,0),colorcyan;
STICKLINE(VarC-VarD< 0,49,50,6,1),colorred;
STICKLINE(VarC-VarD< 0,19,20,6,1),colorred;
STICKLINE(VarC-VarD>0,VarC,VarD,8,1),colorcyan;
STICKLINE(VarC-VarD< 0,VarC,VarD,8,1),colorred;

H三丰KDJ
X1:=(C-LLV(L,9))/(HHV(H,9)-LLV(L,9))*100;
X2:=(C-LLV(L,18))/(HHV(H,18)-LLV(L,18))*100;
X3:=(C-LLV(L,36))/(HHV(H,36)-LLV(L,36))*100;
FK1:=SMA(X1,3,1);三丰K9:SMA(FK1,3,1);
FK2:=SMA(X2,3,1);三丰K18:SMA(FK2,3,1);
FK3:=SMA(X3,3,1);三丰K36:SMA(FK3,3,1);

I魔鬼K线
开:SMA(MAX(O-REF(O,1),0),6,1)/SMA(ABS(O-REF(O,1)),6,1)*100 linethick0;
高:SMA(MAX(H-REF(H,1),0),6,1)/SMA(ABS(H-REF(H,1)),6,1)*100 linethick0;
低:SMA(MAX(L-REF(L,1),0),6,1)/SMA(ABS(L-REF(L,1)),6,1)*100 linethick0;
收:SMA(MAX(C-REF(C,1),0),6,1)/SMA(ABS(C-REF(C,1)),6,1)*100 linethick0;
PARTLINE(C,20);PARTLINE(C,80);PARTLINE(C,90); PARTLINE(C,50);
M5:MA(收,5)colorwhite;M13:MA(收,13)coloryellow;
STICKLINE(收>开,开,高,0,0),colorred;
STICKLINE(收>开,收,开,7,0),colorred;
STICKLINE(收<开,开,高,0,0),COLORgreen;
STICKLINE(收<开,收,开,7,0),COLORgreen;

大米 2006-3-25 06:27
 
关于KDJ多周期、多参数的组合指标使用的个人看法

      前几天我给大家发送的“三丰指标”的WORD原码文件,我今天已经在好几个网站上看到了,我原先的本意是想尽量减少流传的范围,以免被一些与我们散户为敌的人利用,同时,也想减少那些整天想卖指标发财的人的利用的机会。现在看来,我的本意没有达到。这是题外话了。

      今天,我想说的是:传统指标KDJ的多周期、多参数的组合使用。
      首先,我想纠正网上许多兄弟的一个错误的说法,多周期的含义是指跨周期的多种时段的组合的意思,不是指长短参数的。
      二是,KDJ多周期的指标。是指5、15、30、60分钟、日线、周线、月线以及多日线的跨周期的组合的KDJ的指标。现举日周KDJ指标的例子,原码如下:
      三丰日K:"SLOWKD.K#DAY"(9,3,3,3);
      三丰日D:"SLOWKD.D#DAY"(9,3,3,3);
      三丰周K:"SLOWKD.K#WEEK"(93,3,3);
      三丰周D:"SLOWKD.D#WEEK"(9,3,3,3);
      STICKLINE(C>0,20,20,6,0)colorFF9999;
      STICKLINE(C>0,80,80,6,0)colorFF9999;
      STICKLINE(C>0,50,50,6,0)colorred;

      当然,你得有SLOWKD指标,他的原码如下:
      RSV:=(C-LLV(L,N))/(HHV(H,N)-LLV(L,N));
      FK:=SMA(RSV,M1,1);
      K:SMA(FK,M2,1);
      D:SMA(K,M3,1);

      同时,想补充一句:那些将周KD指标值进行曲线优化后的,就已经不是周KD值了。因为,对前期的任何一周的KD值(指已经过去的任何一周),周KD在同一周内应该只有一个指标值,是不变的,不可能是变化的!因此,凡是变化的均是有问题的!!!
      这一点请大家务必要小心,不要上当了!

      三是,KDJ多参数组合的指标。一般是指短、中、长多参数组合的KDJ的指标。现举多参数KDJ指标的例子,原码如下:

      RSV1:=(C-LLV(L,10))/(HHV(H,10)-LLV(L,10))*100;
      RSV2:=(C-LLV(L,30))/(HHV(H,30)-LLV(L,30))*100;
      RSV3:=(C-LLV(L,60))/(HHV(H,60)-LLV(L,60))*100;
      RSV4:=(C-LLV(L,90))/(HHV(H,90)-LLV(L,90))*100;
      FK1:=SMA(RSV1,3,1);三丰K10:SMA(FK1,3,1);
      FK2:=SMA(RSV2,3,1);三丰K30:SMA(FK2,3,1);
      FK3:=SMA(RSV3,3,1);三丰K60:SMA(FK3,3,1);
      FK4:=SMA(RSV4,3,1);三丰K90:SMA(FK4,3,1);
      STICKLINE(C>0,20,20,6,0) colorFF9999;
      STICKLINE(C>0,80,80,6,0) colorFF9999;
      STICKLINE(C>0,50,50,6,0) colorred;   

      这就是目前一些网站上说的多周期组合的KDJ指标了,其实应该是多参数的KDJ指标。就其应用,今天贴上证指数的图例,大家看看就知道该怎么用了。
      不妥之处,请大家提出批评。有什么问题,也请大家提出宝贵意见。
      三丰在此有礼了。


                                             章三丰     2002-11-9

大米 2006-3-25 06:27
 
三丰公式源码[转帖]
不知道对大家是否有用,看到别人贴出来,顺手弄来给大家看看:


三丰礼物1   MACD、RSI、KDJ、TRIX同图显示组合指标
RSI6:SMA(MAX(C-REF(C,1),0),6,1)/SMA(ABS(C-REF(C,1)),6,1)*100;
DIFF:=EMA(C,5)-EMA(C,20);DEA:=EMA(DIFF,10);
MACD:500*(DIFF-DEA)/EMA(C,30) colorred pointdot;
RSV:=(C-LLV(L,20))/(HHV(H,20)-LLV(L,20))*100;
FK:=SMA(RSV,5,1);
K20:SMA(FK,5,1) pointdot COLORyellow;
D20:SMA(K20,5,1) pointdot COLORff9999;
TR:=EMA(EMA(EMA(C,5),5),5);
TRIX:(TR-REF(TR,1))/REF(TR,1)*1000 pointdot colormagenta;
TRMA:EMA(TRIX,30) pointdot colorff8888;
STICKLINE(K20>=D20,D20,K20,10,0) COLORyellow;
STICKLINE(K20<=D20,D20,K20,10,0) COLORff9999;
STICKLINE(MACD>=0,0,MACD,10,0) COLORred;
STICKLINE(MACD<=0,0,MACD,10,0) COLORgreen;
STICKLINE(TRIX>=TRMA,TRIX+60,TRMA+60,10,0) COLORmagenta;
STICKLINE(TRIX<=TRMA,TRIX+60,TRMA+60,10,0) COLORff9999;
三丰礼物2    MACD、RSI、日周KDJ同图显示组合指标
Rsi6:SMA(MAX(C-REF(C,1),0),6,1)/SMA(ABS(C-REF(C,1)),6,1)*100;
MACD:300*"MACD.MACD#DAY"(20,5,10)/EMA(C,30) colorred pointdot;
日K:"SLOWKD.K#DAY"(20,5,5,5) pointdot COLORyellow;
日D:"SLOWKD.D#DAY"(20,5,5,5) pointdot COLORff9999;
周K:"SLOWKD.K#WEEK"(5,3,3,3) pointdot COLORmagenta;
周D:"SLOWKD.D#WEEK"(5,3,3,3) pointdot COLORff9999;
STICKLINE(日K>=日D,日D,日K,10,0) COLORyellow;
STICKLINE(日K<日D,日D,日K,10,0) COLORff9999;
STICKLINE(周K>=周D,周D,周K,10,0) COLORmagenta;
STICKLINE(周K<周D,周K,周D,10,0) COLORff9999;
STICKLINE(MACD>=0,0,MACD,10,0) COLORred;
STICKLINE(MACD<=0,0,MACD,10,0) COLORgreen;

三丰礼物3   MACD、日周KDJ同图显示组合主图指标
MA10:MA(C,10);
MA30:MA(C,30);
MA60:MA(C,60);
MA90:MA(C,90);
MA120:MA(C,120) colorgreen;
MACD:="MACD.MACD"(20,5,10);
K20:="SLOWKD.K"(20,5,5,5);
D20:="SLOWKD.D"(20,5,5,5);
周K:="SLOWKD.K#WEEK"(5,3,3,3);
周D:="SLOWKD.D#WEEK"(5,3,3,3);
L000:=(K20>=D20 AND MACD>=0) OR (周K>=周D
AND MACD>=0) OR (周K>=周D AND K20>=D20);
L001:=K20>=D20 AND 周K>=周D AND MACD>=0;
STICKLINE(L001=0,C,O,6,0) COLORff8888;
STICKLINE(L001=0,H,L,0,0) COLORff8888;
STICKLINE(L000>0,C,O,6,0) COLORyellow;
STICKLINE(L000>0,H,L,0,0) COLORyellow;
STICKLINE(L001>0,C,O,6,0) COLORred;
STICKLINE(L001>0,H,L,0,0) COLORred;
STICKLINE(C<=REF(C,1) AND L001>0,C,O,6,0) COLORgreen;
STICKLINE(C<=REF(C,1) AND L001>0,H,L,0,0) COLORgreen;

SF庄见愁
   庄家筹码估算值:EMA(WINNER(C)*70,3) colormagenta linethick2;
   散户筹码估算值:EMA((WINNER(C*1.1)-WINNER(C*0.9))*70,3) colorgreen linethick2;

SF庄见愁Z
获利线:EMA(WINNER(C)*100,3) colorwhite;
庄筹线:EMA(WINNER(C)*70,5) colorred linethick2;
散筹线:EMA((WINNER(C*1.1)-WINNER(C*0.9))*70,5)colorgreen linethick2;
收:=winner(C)*100;开:=winner(O)*100;
博弈K线长:MAX(ABS(收-开),ABS(收-REF(收,1)))pointdot colormagenta;
STICKLINE(庄筹线>散筹线,庄筹线,散筹线,0,0),COLORred;
stickline(收>REF(收,1),0,博弈K线长,6,0),colormagenta;
stickline(收<REF(收,1),0,博弈K线长,0,0),color999999;

SF太极拳
   KS13:=(CLOSE-MA(CLOSE,13))/MA(CLOSE,13)*(-100);
   REF(KS13,1)>=16 AND REF(KS13,1)/KS13>=1.23;

大道至简,三丰KDJ指标
三丰KDJ指标的原码:
CC:=WINNER(CLOSE)*100;
CO:=WINNER(OPEN)*100;
CH:=WINNER(HIGH)*100;
CL:=WINNER(LOW)*100;
RSV:=(CC-LLV(CL,20))/(HHV(CH,20)-LLV(CL,20))*100;
FK:=SMA(RSV,5,1); K:SMA(FK,5,1);
D:SMA(K,5,1); J: K*3-D*2;
见底买入:IF(REF(K,1)<20 AND CROSS(K,D),30,00)linethick2,colorred;
见顶卖出:IF(REF(K,1)>80 AND CROSS(D,K),60,90)linethick2 colorgreen;

大道至简,三丰MACD指标
三丰MACD指标的原码:
CC:=WINNER(CLOSE)*100;
DIFF:EMA(CC,5)-EMA(CC,20);
DEA:EMA(DIFF,10);
MACD:(DIFF-DEA),COLORSTICK LINETHICK3;

大道至简,三丰TRIX指标
三丰TRIX指标的原码:
CC:=WINNER(CLOSE)*100;
TR:=EMA(EMA(EMA(CC,10),10),10);
TRIX:(TR-REF(TR,1))/REF(TR,1)*100;
TRMA:EMA(TRIX,20);

大道至简,三丰RSI指标
三丰RSI指标的原码:
CC:=WINNER(C);CO:=WINNER(O);CH:=WINNER(H);CL:=WINNER(L);LC:=REF(CC,1);
RSI1:SMA(SMA(MAX(CC-LC,0),6,1)/SMA(ABS(CC-LC),6,1)*100,5,1);
RSI2:SMA(SMA(MAX(CC-LC,0),12,1)/SMA(ABS(CC-LC),12,1)*100,5,1);
RSI3:SMA(SMA(MAX(CC-LC,0),24,1)/SMA(ABS(CC-LC),24,1)*100,5,1);

大道至简,三丰MA指标
三丰MA指标的原码:
CC:=WINNER(C)*100;
MA10:MA(CC,10);
MA30:MA(CC,30);
MA90:MA(CC,90);
MA120:MA(CC,120);
MA250:MA(CC,250);

大道至简,三丰波段指标
首先,声明一点:本指标非我所创,是优化别人的东西而成。
三丰“波段神偷”指标的原码:
Var1:=3*SMA((C-LLV(L,55))/(HHV(H,55)-LLV(L,55))*100,5,1)
-2*SMA(SMA((C-LLV(L,55))/(HHV(H,55)-LLV(L,55))*100,5,1),3,1);
三丰线:EMA(Var1,5) linethick2;
Var2:=(三丰线-REF(三丰线,1))/REF(三丰线,1)*100;
准备资金:STICKLINE(三丰线<13,0,20,5,0)COLORyellow;
买入股票:STICKLINE(REF(三丰线,1)<13 AND Var2>13,0,50,5,0)COLORred;
见顶清仓:STICKLINE(REF(三丰线,1)>90 AND Var2<0,100,80,5,0)COLORgreen;
0 linethick2 color999999;100 linethick2 color999999;

三丰谢幕:仿制指南针遍地黄金及说明
三丰是6月初来巫山的,至今正好两个月。在人的一生中,两个月也许不算长,甚至转瞬即逝,但来巫山的两个月,却让我终生难忘。在三丰谢幕之时,我要衷心感谢巫山的各位兄弟、姐妹!谢谢你们的支持和赏识!衷心感谢阿不版主、俊麟版主、耳朵妹妹、DKLSC版主、DONGFENG兄弟、ZZR007兄弟、蛙兄、YEMA158------谢谢LAOKOU、K13、FOFO、9898------谢谢巫山的所有同仁!
下周开始,我要带人监盘,时间可能不够。同时,我自己认为:公式不是万能的,自己在公式研究方面已经初有成效,但实盘操作方面十分缺乏,尚不能做到十拿七稳,急需进行闭关修炼,因此,巫山的各位兄弟多多体谅我的苦衷了。
   在此谢幕之即,我将指南针的遍地黄金指标的仿制过程公布如下:
一、看了指南针的说明,在股票的开、高、低、收、量五个参数中,能在指南针中用于判断大盘的惟有量的参数,而且是成交额,不是成交量。
二、能用于活筹和个股的指标,肯定不是指南针系统的活筹指标,而应该是通用的成交额的指标。
三、说明中有一句话:2:50后比较准确,这就说明用的肯定是量的指标。
四、说明中说:本指标是一个卖出指标,对买入点比较迟钝,说明了:卖出点判断是一个点的概念,而买入点是一个区域概念。
五、汇总如下:

1、使用于综合大盘的遍地黄金的主图指标的原码:
MA10:MA(C,10);
MA30:MA(C,30);
MA60:MA(C,60);
MA120:MA(C,120);
MA250:MA(C,250);
STICKLINE(C<O,C,O,8,0) COLORgreen;
STICKLINE(C>=O,C,O,8,0) COLORred;
Var1:=SMA(("1A0001$AMOUNT"+"399106$AMOUNT"),10,1);
涨跌A:=(Var1-REF(Var1,1))/REF(Var1,1)*100;
条件A:=(VAR1-LLV(var1,10))/LLV(var1,10)*100>10;
Var2:=SMA(AMOUNT,10,1);
涨跌B:=(Var2-REF(Var2,1))/REF(Var2,1)*100;
条件B:=(VAR2-LLV(var2,10))/LLV(var2,10)*100>15;
STICKLINE(涨跌A<=0,H+0.02,H+0.02,3,0),colorff8888,linethick5;
STICKLINE(条件A=0 and 涨跌A>0,H+0.02,H+0.02,3,0),coloryellow,linethick5;
STICKLINE(条件A>0 and 涨跌A>0,H+0.02,H+0.02,3,0),colormagenta,linethick5;
STICKLINE(涨跌B<=0,L-0.02,L-0.02,3,0),colorFF8888,linethick5;
STICKLINE(条件B=0 and 涨跌B>0,L-0.02,L-0.02,3,0),coloryellow,linethick5;
STICKLINE(条件B>0 and 涨跌B>0,L-0.02,L-0.02,3,0),colormagenta,linethick5;

2、通用的遍地黄金的副图指标的原码:如KDJ指标
RSV:=(C-LLV(L,20))/(HHV(H,20)-LLV(L,20))*100;
三丰K:SMA(RSV,10,1);
三丰D:SMA(三丰K,5,1);
三丰J:三丰K*3-三丰D*2;
Var1:=SMA(("1A0002$AMOUNT"+"399107$AMOUNT"),10,1);
涨跌A:=(Var1-REF(Var1,1))/REF(Var1,1)*100;
条件A:=(VAR1-LLV(var1,10))/LLV(var1,10)*100>10;
Var2:=SMA(AMOUNT,10,1);
涨跌B:=(Var2-REF(Var2,1))/REF(Var2,1)*100;
条件B:=(VAR2-LLV(var2,10))/LLV(var2,10)*100>15;
STICKLINE(涨跌A<=0,100,110,5,1),colorff8888;
STICKLINE(条件A=0 and 涨跌A>0,100,110,5,1),coloryellow;
STICKLINE(条件A>0 and 涨跌A>0,100,110,5,1),colorred;
STICKLINE(涨跌B<=0,0,-10,5,1),colorFF8888;
STICKLINE(条件B=0 and 涨跌B>0,0,-10,5,1),coloryellow;
STICKLINE(条件B>0 and 涨跌B>0,0,-10,5,1),colorred;

                               章三丰    2002-08-08

章三丰筹码正谈之一二(合并)
由于昨天有人扫了兴趣,一下子打不起精神(由于看盘比较累、打字又是弱项,写篇文章真的很累,因为自己不会五笔,拼音又很不标准,南方人嘛!真累!)同时,还有点私心,不想将自己的好东西无偿的给予那些不识货的人,更不想给予那些不知好歹的人(例如巫山的“共青团”、“99992”之流)!但是,既然开了口,不说的话,又总感觉对不起巫山对我很好的众兄弟,象阿不、俊嶙、LIMM1234、ZZR007几位版主,象DONGFENG、LAOKOU、K13、蛙兄等,也对不起那些真的很想来巫山学点东西的兄弟,如CYQCYQ等。未提及的兄弟见谅。
好了,长话短说。我将正说一二和并,同时,筹码分布的长短讨论略过(有时间大家再来争论吧!),我的一点看法也省去,直接说说筹码分布在实战中的运用。首先,大家不用怀疑筹码分布的实战性,因为,任何一种技术方法,必有优点,也有缺点,正如我前天所说的那样:只要优点明显、而缺点能加以克服的技术方法,包括指标、公式,都是能够让我们在股市中获利的。其次,筹码分布的运用的好坏,还跟你的水平有关,包括对筹码分布的优缺点的深刻理解,特别是缺陷的理解!包括你运用筹码分布的技巧,运用其他相关技术的技巧;还包括你对大盘的认知的程度、对趋势、波浪理论的基本认识等等。说白了,股市中的任何一种挣钱的技巧,都是综合应用,基础都是差不多的,只不过主攻方向不同而已。当你到了融会贯通之时,也是你到了无招胜有招的时候了!
好,运用筹码分布实战之前,请大家建立以下“庄见愁”指标,我用分析家来论述。已经有庄见愁指标的兄弟就不要重建了。
   庄筹线:EMA(WINNER(C)*70,5) colorred linethick2;
   散筹线:EMA((WINNER(C*1.1)-WINNER(C*0.9))*80,5)colorgreen linethick2;
5;20;40;60;

方法之一:抄底的运用。方法名称是:海底捞活鱼
技术要点:1、庄筹线在5以下,接近0最好,表示全盘被套;
         2、散筹线也在5以下,表示上部有反弹空间;
         3、股价远离均线系统,形成超跌状态;
买入要点:在以上状态时密切加以关注,一旦出现放量上攻时果断介入!
买入要求:一定要是一条活鱼,死鱼不要!也就是说,涨幅越大越好,量比也要放大。热点板块的龙头为首选。
其他要求:大盘能配合最好;老庄股不要;老牛股不要;妖股不要;暴量的不要。
实战例子:000412  000562 

方法之二:洗盘的运用。方法名称是:决战诱空
技术要点:1、庄筹线曾40-50以上,表示庄家已经达到中控盘以上;
         2、庄筹线快速杀跌至20上下,表示庄家有意打压;
         3、股价中期均线系统,趋势走平或向上;
买入要点:在以上状态时密切加以关注,一旦出现见底反转时果断介入!
买入要求:杀跌时一定要缩量!前期一定要有过1浪的上升浪,现在杀跌的必须是2浪调整浪;杀跌的时间要短,5-10个交易日为好;前期的热点板块龙头股为首选。
其他要求:大盘要平稳;老庄股不要;老牛股不要;妖股不要;暴量的不要。
实战例子:600817  000008   000963

方法之三:主升段的运用。方法名称是:鸡雀升天(追随庄家得道升天)
技术要点:1、散筹线在30以上,快速向下溃败;
         2、庄筹线在30以下,快速向上攻击,形成金叉;
         3、股价均线系统趋势向上,出现量价齐升的局面;
买入要求:放量一定要适度,暴量的个股不要!前期一定要有过1浪上升、2浪调整;成为热点板块为首选。
其他要求:大盘要平稳;老庄股不要;老牛股不要;妖股不要;暴量的不要。
实战例子:600217  600057 

好了,这就是我的三招,我的任务完成了。请大家注意以下几点:
一、希望大家永不再贴本贴的内容,不要传播。因为,股市是少数人挣多数人的钱的杀人不见血的战场,一个方法用的人多了,就会死翘翘。特别是遇到主力反做时,我们也就死翘翘了,因此,特别不要告诉机构、大户。
二、本办法比较适用于小资金散户的实战,大资金要注意隐蔽,不要惊动庄家,以免庄家来折磨你!
       各位兄弟,俺走了,希望大家在股市里也一路走好!再见!

                          章三丰      2002-09-07
        
分笔成交数据的系列基础指标
承蒙易股的ZXZM妹妹(或姐姐)的启发,特编写系列分笔成交数据的运用指标,今天送给大家。由于我也是第一次编写此类指标,比较生疏,定有不当之处,还望大家笑纳并提出修改意见,以利共同提高。
同时,由于我以前不太重视分笔成交数据的保存,因此,本系列指标的效果图就无法贴了,有请哪位兄弟姐妹贴几个图看看。
指标一:GDFSZJ
zjmj:=sum(if(buyvol>=100,vol,0),0);
zjmc:=sum(if(sellvol>=100,vol,0),0);
ddbs:=count(sum(if(buyvol>=100,vol,0),0) or
sum(if(sellvol>=100,vol,0),0),0);
sfmb:=(sum(vol,0)-sum(if(buyvol>=100,vol,0),0)-sum(if(sellvol>=100,vol,0),0))/(BARSCOUNT(c)-ddbs);
gdfszj:(zjmc-zjmj)/sfmb;
对应建立扩展数据库文件的“数据1”,见图例。

指标二:股东分布    日线
gd:=EXTDATA(1);
gdbs:=10000+sum(gd,0);
模拟股东数:10000+sum(gd,0);
变动均线:ma(gdbs,13);

指标三:每日庄买   
每日庄买:sum(if(buyvol>=100,vol,0),0);
对应建立扩展数据库文件的“数据4”,见图例。

指标四:每日庄卖
每日庄卖:sum(if(sellvol>=100,vol,0),0);
对应建立扩展数据库文件的“数据5”,见图例。

指标五:每日总买(每日主动性买单总和)
每日买单总和:sum(buyvol,0);
对应建立扩展数据库文件的“数据2”,见图例。

指标六:每日总卖(每日主动性卖单总和)
每日卖单总和:sum(sellvol,0);
对应建立扩展数据库文件的“数据3”,见图例。

指标七:牛熊OBV(每日主动性买单与主动性卖单的差的OBV)
牛熊OBV:SUM((EXTDATA(2)-EXTDATA(3)),0)/10000 COLORmagenta;

指标八:牛资均线(每日主动性买单与主动性卖单的差的均线系统)
VAR1:=(EXTDATA(2)-EXTDATA(3))/100;
资金5:EMA(VAR1,5) COLORRED;
资金13:EMA(VAR1,13) COLORYELLOW;
资金34:EMA(VAR1,34) COLORGREEN;

指标九:日委买量(每日挂一、挂二、挂三的委买量的总和)
每日委买量:SUM((BIDVOL(1)+BIDVOL(2)+BIDVOL(3)),0);
对应建立扩展数据库文件的“数据6”,见图例。

指标十:日委卖量(每日挂一、挂二、挂三的委卖量的总和)
每日委卖量:SUM((ASKVOL(1)+ASKVOL(2)+ASKVOL(3)),0);
对应建立扩展数据库文件的“数据7”,见图例。

指标十一:委买OBV(每日挂一、挂二、挂三的委买量的总和的OBV指标)
委买OBV:SUM(EXTDATA(6),0)/1000000 COLORmagenta;

指标十二:委卖OBV(每日挂一、挂二、挂三的委卖量的总和的OBV指标)
委卖OBV:SUM(EXTDATA(7),0)/1000000 COLORmagenta;

指标十三:庄家OBV
庄家OBV:SUM((EXTDATA(4)-EXTDATA(5)),0)/10000 COLORmagenta;

指标十四:庄资均线
VAR1:=(EXTDATA(4)-EXTDATA(5))/100;
庄资金5:EMA(VAR1,5) COLORRED;
庄资金13:EMA(VAR1,13) COLORYELLOW;
庄资金34:EMA(VAR1,34) COLORGREEN;

以上的十四个指标,第一、第二个是文章中的,后面的十二个是我写的。虽然简单,但我发现其意义十分重大。分笔数据是发现庄家踪迹的最好的原始资料,我们以前都没有很好利用过。

                         章三丰        2002-09-12

大米 2006-3-25 06:27
 
章三丰:我的均线指标
相信看过青木老师“登峰之路”的朋友,对青木老师的深厚功底和云海闲情所折服。在书中,有两课讲到了移动平均线,我对青木老师讲的“均线流”比较感兴趣,今天,特将均线流的指标和OL指标的原码公布如下,望兄弟们笑纳。
均线流指标一、指标名“三丰LMA”
MA5:MA(C,5);
MA10:MA(C,10)coloryellow;
MA30:MA(C,30)colorgreen;
MA90:MA(C,90)colormagenta;
MA120:MA(C,120)colorcccccc;
MA250:MA(C,250)colorred;
MA(C,20)color666666;
MA(C,50)color666666;
MA(C,70)color666666;
MA(C,150)color666666;
MA(C,180)color666666;
MA(C,210)color666666;

均线流指标二、指标名“三丰EMA”
EMA5:EMA(C,5);
EMA10:EMA(C,10)coloryellow;
EMA30:EMA(C,30)colorgreen;
EMA90:EMA(C,90)colormagenta;
EMA120:EMA(C,120)colorcccccc;
EMA250:EMA(C,250)colorred;
EMA(C,20)color666666;
EMA(C,50)color666666;
EMA(C,70)color666666;
EMA(C,150)color666666;
EMA(C,180)color666666;
EMA(C,210)color666666;

均线流指标三、指标名“三丰SMA”
SMA5:SMA(C,5,1);
SMA10:SMA(C,10,1)coloryellow;
SMA30:SMA(C,30,1)colorgreen;
SMA90:SMA(C,90,1)colormagenta;
SMA120:SMA(C,120,1)colorcccccc;
SMA250:SMA(C,250,1)colorred;
SMA(C,20,1)color666666;
SMA(C,50,1)color666666;
SMA(C,70,1)color666666;
SMA(C,150,1)color666666;
SMA(C,180,1)color666666;
SMA(C,210,1)color666666;

至于大家喜欢哪个均线流指标,大家各取所需吧!同时,还想增加或减少均线的数量,大家也自己动手试一试。

   以上三个指标,对于控盘个股、走上升浪时十分有用;但对其他行情时,有时会觉得这些均线有点眼花缭乱,我自己在平时一般就去掉均线系统,留下K线,这就是我的“OL”指标了。下面是“OL”的原码:

   指标四、指标名“三丰OL”
KS:=(C-MA(C,13))/MA(C,13)*(-100);
RKS:=REF(KS,1);
MLS:=RKS/KS>=1.23 AND RKS>=8 AND C/REF(C,1)>=1.02;
超跌:STICKLINE(KS>=8,H,L,0,1),colorwhite,linethick2;
反弹:STICKLINE(MLS=1,H,L,0,1),colormagenta,linethick2;
STICKLINE(C>=O,C,O,8,0) COLORred;
STICKLINE(C<=O,C,O,8,0) COLORgreen;
STICKLINE(KS>=8,O,C,8,1),colorwhite,linethick2;
STICKLINE(MLS=1,O,C,8,1),colormagenta,linethick2;
EMA(C,10)colorcyan;
EMA(KS/10+EMA(C,10),3)colorff8888;

好了,我实战的均线系统就这些了,大家喜欢的话,就用用吧。
另外,大家也可以根据自己的喜好、特点,再进一步组合、优化。
还是那句话:适用的就是最好的!

                        章三丰        2002-09-13


三丰筹码(主图指标)
原码:
COST5:POLYLINE(c>0,cost(05));
aa03:=POLYLINE(c>0,cost(10));
aa04:=POLYLINE(c>0,cost(15));
aa05:=POLYLINE(c>0,cost(20));
aa06:=POLYLINE(c>0,cost(25));
aa07:=POLYLINE(c>0,cost(30));
aa08:=POLYLINE(c>0,cost(35));
aa09:=POLYLINE(c>0,cost(40));
aa10:=POLYLINE(c>0,cost(45));
aa11:=POLYLINE(c>0,cost(50));
aa12:=POLYLINE(c>0,cost(55));
aa13:=POLYLINE(c>0,cost(60));
aa14:=POLYLINE(c>0,cost(65));
aa15:=POLYLINE(c>0,cost(70));
aa16:=POLYLINE(c>0,cost(75));
aa17:=POLYLINE(c>0,cost(80));
aa18:=POLYLINE(c>0,cost(85));
COST90:cost(90) color999999;
STICKLINE(C>=O,C,O,8,0) COLORred;
STICKLINE(C<=O,C,O,8,0) COLORgreen;

三丰筹码主图指标的应用初探
昨天,我弄了个三丰筹码的主图指标,今天趁大盘要死不活之际,抽了点时间对这个指标研究了一番,感觉该指标对抄底、突破、追涨(老道生平就喜欢这三招,别的招数一概不喜欢、也未加研究,故也不评说!请各位兄弟见谅。),还有一定的功效。现在简单分析如下,权作抛砖引玉之用。
一、抄底
股价远离均线系统形成超跌,且股价远离COST5均线,COST5—COST20等几条均线间距较大的,在其放量上涨时抄底。从筹码分布的角度理解就是,股价超跌、上方筹码稀疏、有较大的反弹空间。今年的一批超跌反弹牛股,许多都是这种形态,如000009、000019、000029、000040等。
二、突破
主要是指横盘突破这类股票。股价长期横盘,三丰筹码指标中的COST20--COST70等的均线紧密排列,形成筹码密集,股价始终站在稠密均线之上,此时,若大盘见好,则此类个股将会成功突破。2001年上半年的许多个股均有这种表现,如000594等。
还有一类个股是成功突破筹码密集均线后,形成主升浪,如近期的000835。
三、追涨
股价站上筹码密集均线后形成主升浪,而此时,中底部筹码均线锁定良好,基本上没有变动,此时追涨比较安全,因为你骑上的是一匹锁仓拉升的庄股,例如:600309的主升段。近期的600057也有点这种味道,只是味道不浓。
请大家将自己发现的个股,贴上图来,供大家相互学习、研究。
                  章三丰          2002-09-18


迎国庆,送小礼!
指标一:三丰+KDJ 

RSV1:=(C-LLV(L,20))/(HHV(H,20)-LLV(L,20));
RSV2:=(RSV1-0.5)*EMA(C,20)/5;
三丰K:=SMA(RSV2,5,1);
三丰D:=SMA(三丰K,5,1);
三丰J:=三丰K*3-三丰D*2;
三丰K+EMA(C,20) colorwhite;
三丰D+EMA(C,20) coloryellow;
三丰J+EMA(C,20) colormagenta;
STICKLINE(C>=O,C,O,6,0) COLORred;
STICKLINE(C>=O,H,L,0,0) COLORred;
STICKLINE(C<=O,C,O,6,0) COLORgreen;
STICKLINE(C<=O,H,L,0,0) COLORgreen;


指标二:三丰+MACD

DIFF:=EMA(C,5)-EMA(C,20);
DEA:=EMA(DIFF,10);
DIFF*3+EMA(C,20)*0.95;
DEA*3 +EMA(C,20)*0.95;
STICKLINE(C>=O,C,O,6,0) COLORred;
STICKLINE(C>=O,H,L,0,0) COLORred;
STICKLINE(C<O,C,O,6,0) COLORgreen;
STICKLINE(C<O,H,L,0,0) COLORgreen;

指标说明:
一、以上两个指标,都很简单,没有任何花哨的东西,既可以作主图用,也可以作副图指标,同时可以自己添加均线、文字等东西;
二、指标中的KDJ、MACD,其实已经不是真正的传统的KDJ、MACD指标了,但其原理仍在,使用方法仍然相通,原指标的深刻含义都在;
三、指标中的KDJ、MACD已经叠加了EMA(C,20)这条均线的趋势,是一种叠加后的效果,在KDJ、MACD钝化的时候,如果均线仍然向上,则可以消化其钝化!
四、平时喜欢KDJ、MACD等传统指标的兄弟,可能会比较喜欢,因此,也想请你们将不同的想法贴上来,让大家一起来共同学习、提高;
五、以上KDJ、MACD指标的参数,大家可以自己调整,还是那句老话:适用的就是最好的!
六、以上指标是我的原创,如有雷同,纯属巧合!

                   章三丰           2002/9/30


三丰关于“三丰+MACD”和“三丰+KDJ”指标参数的说明

前天,我发了“三丰+MACD”和“三丰+KDJ”两个指标,主要解决了MACD的滞后和KDJ的高位钝化问题,指标中的参数MACD(20,5,10)和KDJ(20,5,5)是我自己最喜欢使用的两组参数。但这两组参数主要是针对日线分析周期的。今天看到网上有兄弟拿这两组参数对月线进行分析,本人怕有误导,特对参数的调整问题提出如下个人看法,以便给那些对公式、指标不太熟练、自己调整参数有困难的兄弟作一个参考。
一、周月周期分析:建议使用的参数是MACD为(10,3,5),KDJ为(8,3,3);
二、日线周期分析:建议使用给定的参数;
三、分时周期分析:建议使用的参数是MACD为(30,10,10),KDJ为(30,10,5)。
有能力自己调整的兄弟,请自己动手,调出自己适用的参数,不必苛求我给的参数。

               章三丰        诚惶诚恐  于2002/10/2


加入收藏
继续查看选择: > manbetx官方网站>   
 
 

 

 

最新短信回顾 ※

最新传真回顾


热线电话: 0734-8878222
13187333584
微信联系:gupiao139
 
网页在线股票咨询

热门文章点击排行